aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorXan Lopez <xan@src.gnome.org>2009-03-12 22:14:10 +0800
committerXan Lopez <xan@src.gnome.org>2009-03-12 22:14:10 +0800
commit10968f2b59143f15aadbd4f6be12a3f680216aa8 (patch)
tree745563dfbf0f8a63c21d3adcdd89a88f733a48ec /configure.ac
parent8bac92b3be8a6cc75b8d5ea6179b4258638a38ff (diff)
downloadgsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.tar
gsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.tar.gz
gsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.tar.bz2
gsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.tar.lz
gsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.tar.xz
gsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.tar.zst
gsoc2013-epiphany-10968f2b59143f15aadbd4f6be12a3f680216aa8.zip
configure.ac: require avahi-client explictly.
avahi-client is in the private requiremenets of avahi-gobject, so we need to ask for it to get the right libs at link time. svn path=/trunk/; revision=8871
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 850af4be6..fd9f0b471 100644
--- a/configure.ac
+++ b/configure.ac
@@ -387,7 +387,10 @@ AC_MSG_RESULT([$enable_zeroconf])
if test "$enable_zeroconf" != "no"; then
AVAHI_REQUIRED=0.6.22
- PKG_CHECK_MODULES(AVAHI, [avahi-gobject >= $AVAHI_REQUIRED],[have_avahi=yes],[have_avahi=no])
+ PKG_CHECK_MODULES(AVAHI,
+ [avahi-gobject >= $AVAHI_REQUIRED
+ avahi-client >= $AVAHI_REQUIRED]
+ ,[have_avahi=yes],[have_avahi=no])
if test "$enable_zeroconf" = "yes" -a "$have_avahi" = "no"; then
AC_MSG_ERROR([zeroconf support was requested but avahi not found])