aboutsummaryrefslogtreecommitdiffstats
path: root/trunk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trunk/Makefile.am')
-rw-r--r--trunk/Makefile.am56
1 files changed, 56 insertions, 0 deletions
diff --git a/trunk/Makefile.am b/trunk/Makefile.am
new file mode 100644
index 000000000..4d552e25b
--- /dev/null
+++ b/trunk/Makefile.am
@@ -0,0 +1,56 @@
+SUBDIRS = tools extensions po data libempathy libempathy-gtk src docs help
+
+if HAVE_MEGAPHONE
+SUBDIRS += megaphone
+endif
+
+if HAVE_NOTHERE
+SUBDIRS += nothere
+endif
+
+if HAVE_PYTHON
+SUBDIRS += python
+endif
+
+if HAVE_TESTS
+SUBDIRS += tests
+endif
+
+ACLOCAL_AMFLAGS = -I m4
+
+DISTCHECK_CONFIGURE_FLAGS = \
+ --disable-scrollkeeper \
+ --disable-schemas-install \
+ --enable-gtk-doc
+
+INTLTOOL = \
+ intltool-extract.in \
+ intltool-merge.in \
+ intltool-update.in
+
+EXTRA_DIST = \
+ ChangeLog \
+ ChangeLog.old \
+ README \
+ CONTRIBUTORS \
+ autogen.sh \
+ $(INTLTOOL)
+
+DISTCLEANFILES = \
+ ChangeLog \
+ intltool-extract \
+ intltool-merge \
+ intltool-update
+
+# Workaround broken scrollkeeper that doesn't remove its files on
+# uninstall.
+distuninstallcheck_listfiles = find . -type f -print | grep -v '^\./var/scrollkeeper'
+
+ChangeLog: Makefile.am
+ git-log --pretty=short > ChangeLog
+
+
+dist: ChangeLog
+
+.PHONY: ChangeLog
+