aboutsummaryrefslogtreecommitdiffstats
path: root/tp-account-widgets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tp-account-widgets/Makefile.am')
-rw-r--r--tp-account-widgets/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tp-account-widgets/Makefile.am b/tp-account-widgets/Makefile.am
index 3aafe3df9..7bbe9f1cc 100644
--- a/tp-account-widgets/Makefile.am
+++ b/tp-account-widgets/Makefile.am
@@ -7,9 +7,14 @@ AM_CPPFLAGS = \
-DG_LOG_DOMAIN=\"empathy\" \
-DGCR_API_SUBJECT_TO_CHANGE \
$(EMPATHY_CFLAGS) \
+ $(UDEV_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
+libtp_account_widgets_LIBADD = \
+ $(UDEV_LIBS) \
+ $(NULL)
+
BUILT_SOURCES = \
tpaw-account-widgets-resources.c \
tpaw-account-widgets-resources.h \
@@ -62,6 +67,11 @@ libtp_account_widgets_headers = \
totem-subtitle-encoding.h \
$(NULL)
+nocheck_sources = \
+ cheese-camera-device-monitor.c \
+ cheese-camera-device-monitor.h \
+ $(NULL)
+
pkglib_LTLIBRARIES = libtp-account-widgets.la
# libtp-account-widgets's API is not stable and will never be, so use -release to make the
@@ -74,6 +84,7 @@ libtp_account_widgets_la_LDFLAGS = \
libtp_account_widgets_la_SOURCES = \
$(libtp_account_widgets_sources) \
$(libtp_account_widgets_headers) \
+ $(nocheck_sources) \
$(NULL)
# these are sources that depend on Ubuntu Online Accounts