aboutsummaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile.am5
-rw-r--r--tests/test-empathy-account-assistant.c2
2 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eb5dba529..8ffdae723 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -37,6 +37,11 @@ test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
test_empathy_account_assistant_SOURCES = test-empathy-account-assistant.c
+test_empathy_account_assistant_CFLAGS = -I$(top_srcdir)/src
+test_empathy_account_assistant_LDADD = \
+ $(top_builddir)/src/empathy-account-assistant.o \
+ $(LDADD)
+
check_PROGRAMS = check-main
TESTS = check-main
check_main_SOURCES = \
diff --git a/tests/test-empathy-account-assistant.c b/tests/test-empathy-account-assistant.c
index 5add95881..f1f519d77 100644
--- a/tests/test-empathy-account-assistant.c
+++ b/tests/test-empathy-account-assistant.c
@@ -3,7 +3,7 @@
#include <gtk/gtk.h>
#include <libempathy-gtk/empathy-ui-utils.h>
-#include <libempathy-gtk/empathy-account-assistant.h>
+#include "empathy-account-assistant.h"
int main (int argc, char **argv)
{