aboutsummaryrefslogtreecommitdiffstats
path: root/tests/interactive/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/interactive/Makefile.am')
-rw-r--r--tests/interactive/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/tests/interactive/Makefile.am b/tests/interactive/Makefile.am
new file mode 100644
index 000000000..a66f518e9
--- /dev/null
+++ b/tests/interactive/Makefile.am
@@ -0,0 +1,35 @@
+AM_CPPFLAGS = \
+ $(ERROR_CFLAGS) \
+ -I$(top_srcdir) \
+ -DPKGDATADIR=\""$(pkgdatadir)"\" \
+ $(EMPATHY_CFLAGS) \
+ $(WARN_CFLAGS) \
+ $(DISABLE_DEPRECATED)
+
+LDADD = \
+ $(top_builddir)/libempathy-gtk/libempathy-gtk.la \
+ $(top_builddir)/libempathy/libempathy.la \
+ $(EMPATHY_LIBS)
+
+noinst_PROGRAMS = \
+ contact-manager \
+ empetit \
+ test-empathy-account-assistant \
+ test-empathy-presence-chooser \
+ test-empathy-status-preset-dialog \
+ test-empathy-protocol-chooser
+
+contact_manager_SOURCES = contact-manager.c
+empetit_SOURCES = empetit.c
+test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
+test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
+test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
+test_empathy_account_assistant_SOURCES = test-empathy-account-assistant.c
+
+test_empathy_account_assistant_CFLAGS = -I$(top_srcdir)/src
+test_empathy_account_assistant_LDADD = \
+ $(top_builddir)/src/empathy-account-assistant.o \
+ $(top_builddir)/src/empathy-import-utils.o \
+ $(top_builddir)/src/empathy-import-pidgin.o \
+ $(top_builddir)/src/empathy-import-widget.o \
+ $(LDADD)