aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 4780adab5..d0b7fd36d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -26,7 +26,8 @@ LDADD = \
TEST_PROGS = \
empathy-utils-test \
empathy-irc-server-test \
- empathy-irc-network-test
+ empathy-irc-network-test \
+ empathy-irc-network-manager-test
empathy_utils_test_SOURCES = empathy-utils-test.c \
test-helper.c test-helper.h
@@ -39,6 +40,11 @@ empathy_irc_network_test_SOURCES = empathy-irc-network-test.c \
test-helper.c test-helper.h \
check-irc-helper.h check-irc-helper.c
+empathy_irc_network_manager_test_SOURCES = empathy-irc-network-manager-test.c \
+ test-helper.c test-helper.h \
+ check-irc-helper.h check-irc-helper.c \
+ check-empathy-helpers.h check-empathy-helpers.c
+
check_PROGRAMS = check-main $(TEST_PROGS)
TESTS = check-main
@@ -51,7 +57,6 @@ check_main_SOURCES = \
check-empathy-helpers.c \
check-irc-helper.h \
check-irc-helper.c \
- check-empathy-irc-network-manager.c \
check-empathy-chatroom.c \
check-empathy-chatroom-manager.c