aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am42
1 files changed, 23 insertions, 19 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 83b071790..86ffade6b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,29 +1,33 @@
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -DPREFIX="\"$(prefix)"\" \
- -DSYSCONFDIR=\""$(sysconfdir)"\" \
- -DDATADIR=\""$(datadir)"\" \
- -DLIBDIR=\""$(libdir)"\" \
- $(EMPATHY_CFLAGS) \
- $(WARN_CFLAGS)
-
-LDADD = \
- $(top_builddir)/libempathy/libempathy.la \
+cflags = $(EMPATHY_CFLAGS) \
+ $(WARN_CFLAGS)
+
+libs = $(top_builddir)/libempathy/libempathy.la \
$(top_builddir)/libempathy-gtk/libempathy-gtk.la \
$(EMPATHY_LIBS)
bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
-empathy_SOURCES = \
- empathy-main.c
-empathy_accounts_SOURCES = \
- empathy-accounts-main.c
+empathy_SOURCES = empathy-main.c
+empathy_CPPFLAGS = $(cflags)
+empathy_LDFLAGS = $(libs)
+
+empathy_accounts_SOURCES = empathy-accounts-main.c
+empathy_accounts_CPPFLAGS = $(cflags)
+empathy_accounts_LDFLAGS = $(libs)
+
+empathy_chat_SOURCES = empathy-chat-main.c
+empathy_chat_CPPFLAGS = $(cflags)
+empathy_chat_LDFLAGS = $(libs)
-empathy_chat_SOURCES = \
- empathy-chat-main.c
+empathy_contact_list_SOURCES = empathy-contact-list-main.c
+empathy_contact_list_CPPFLAGS = $(cflags)
+empathy_contact_list_LDFLAGS = $(libs)
-empathy_contact_list_SOURCES = \
- empathy-contact-list-main.c
+# MC plugin
+pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
+libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
+libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
+libempathy_filter_plugin_la_LDFLAGS = $(MISSION_CONTROL_PLUGINS_LIBS)
# Dbus service file
servicedir = $(datadir)/dbus-1/services