aboutsummaryrefslogtreecommitdiffstats
path: root/pixmaps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pixmaps/Makefile.am')
-rw-r--r--pixmaps/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/pixmaps/Makefile.am b/pixmaps/Makefile.am
index 11df65cf9..6143ddc2e 100644
--- a/pixmaps/Makefile.am
+++ b/pixmaps/Makefile.am
@@ -15,12 +15,14 @@ image_DATA = \
gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-install-data-hook:
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
@-if test -z "$(DESTDIR)"; then \
echo "Updating Gtk icon cache."; \
$(gtk_update_icon_cache); \
else \
- echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
echo "*** $(gtk_update_icon_cache)"; \
fi