aboutsummaryrefslogtreecommitdiffstats
path: root/pixmaps/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pixmaps/Makefile.am')
-rw-r--r--pixmaps/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/pixmaps/Makefile.am b/pixmaps/Makefile.am
new file mode 100644
index 000000000..11df65cf9
--- /dev/null
+++ b/pixmaps/Makefile.am
@@ -0,0 +1,30 @@
+imagedir = $(datadir)/empathy
+
+image_DATA = \
+ gossip-offline.png \
+ gossip-available.png \
+ gossip-busy.png \
+ gossip-away.png \
+ gossip-extended-away.png \
+ gossip-pending.png \
+ gossip-message.png \
+ gossip-typing.png \
+ gossip-group-message.png \
+ vcard_16.png \
+ vcard_48.png
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(image_DATA)
+
+