aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am23
1 files changed, 16 insertions, 7 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 36de4d6c2..5f4059f20 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -2,8 +2,7 @@ include $(top_srcdir)/tools/flymake.mk
AM_CPPFLAGS = \
$(ERROR_CFLAGS) \
- -I. \
- -I$(top_srcdir) \
+ -I$(top_srcdir)/extensions \
-I$(top_builddir) \
-DDATADIR=\""$(datadir)"\" \
-DLOCALEDIR=\""$(datadir)/locale"\" \
@@ -21,6 +20,8 @@ AM_CPPFLAGS = \
$(DISABLE_DEPRECATED)
BUILT_SOURCES = \
+ empathy-dtd-resources.c \
+ empathy-dtd-resources.h \
empathy-enum-types.h \
empathy-enum-types.c
@@ -134,8 +135,7 @@ libempathy_la_LIBADD = \
$(UOA_LIBS) \
$(LIBM)
-dtddir = $(datadir)/empathy
-dtd_DATA = \
+dtd_resources_files = \
empathy-status-presets.dtd \
empathy-contact-groups.dtd \
empathy-chatroom-manager.dtd \
@@ -145,8 +145,17 @@ ircnetworksdir = $(datadir)/empathy
ircnetworks_DATA = \
irc-networks.xml
-EXTRA_DIST = \
- $(dtd_DATA) \
+dtd_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/empathy-dtd.gresource.xml)
+
+empathy-dtd-resources.c: empathy-dtd.gresource.xml $(dtd_resource_files)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-dtd-resources.h: empathy-dtd.gresource.xml $(dtd_resource_files)
+ $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
+
+EXTRA_DIST = \
+ empathy-dtd.gresource.xml \
+ $(dtd_resources_files) \
$(ircnetworks_DATA)
CLEANFILES = \
@@ -189,7 +198,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
--fhead "G_BEGIN_DECLS\n\n" \
--ftail "G_END_DECLS\n\n" \
--ftail "#endif /* __LIBEMPATHY_ENUM_TYPES_H__ */\n" \
- --fprod "#include <libempathy/@filename@>\n" \
+ --fprod '#include "@filename@"\n' \
--eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
--eprod "GType @enum_name@_get_type (void);\n" \
$(libempathy_headers) ) > xgen-gth \