aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index a114ad7c8..5d0c021b2 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -8,6 +8,7 @@ AM_CPPFLAGS = \
BUILT_SOURCES = \
empathy-marshal.h \
empathy-marshal.c \
+ empathy-marshal.list \
empathy-enum-types.h \
empathy-enum-types.c \
empathy-filter-glue.h \
@@ -84,6 +85,17 @@ libempathy_include_HEADERS = \
$(libempathy_headers) \
empathy-enum-types.h
+empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
+ ( cd $(srcdir) && \
+ sed -n -e 's/.*empathy_marshal_\([[:upper:]]*__[[:upper:]_]*\).*/\1/p' \
+ $(libempathy_la_SOURCES) ) \
+ | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
+ if cmp -s $@.tmp $@; then \
+ rm $@.tmp; \
+ else \
+ mv $@.tmp $@; \
+ fi
+
%-marshal.h: %-marshal.list Makefile
$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h