aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index 571980dd8..40a7c0379 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -66,7 +66,7 @@ libempathy_headers = \
empathy-types.h \
empathy-utils.h
-libempathy_la_SOURCES = \
+libempathy_handwritten_source = \
$(libempathy_headers) \
action-chain.c \
empathy-account-settings.c \
@@ -105,6 +105,10 @@ libempathy_la_SOURCES = \
empathy-tp-streamed-media.c \
empathy-utils.c
+libempathy_la_SOURCES = \
+ $(libempathy_handwritten_source) \
+ cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+
# do not distribute generated files
nodist_libempathy_la_SOURCES =\
$(BUILT_SOURCES)
@@ -118,8 +122,7 @@ libempathy_la_LIBADD = \
$(CONNMAN_LIBS)
check_c_sources = \
- $(libempathy_la_SOURCES) \
- $(libempathy_headers)
+ $(libempathy_handwritten_source)
include $(top_srcdir)/tools/check-coding-style.mk
check-local: check-coding-style