aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index c184fde44..9882d6a71 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -132,12 +132,12 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
mv $@.tmp $@; \
fi
-%-marshal.h: %-marshal.list Makefile
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+empathy-marshal.h: empathy-marshal.list Makefile
+ $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_empathy_marshal $< > empathy-marshal.h
-%-marshal.c: %-marshal.list Makefile
+empathy-marshal.c: empathy-marshal.list Makefile
$(AM_V_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
+ $(GLIB_GENMARSHAL) --body --prefix=_empathy_marshal $< >> empathy-marshal.c
empathy-enum-types.h: stamp-empathy-enum-types.h
$(AM_V_GEN)true