aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy/Makefile.am')
-rw-r--r--libempathy/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/libempathy/Makefile.am b/libempathy/Makefile.am
index c681aa83f..98349b205 100644
--- a/libempathy/Makefile.am
+++ b/libempathy/Makefile.am
@@ -1,11 +1,12 @@
AM_CPPFLAGS = \
- -I. \
- -I$(top_srcdir) \
-DDATADIR=\""$(datadir)"\" \
-DLOCALEDIR=\""$(datadir)/locale"\" \
- $(EMPATHY_CFLAGS) \
+ $(LIBEMPATHY_CFLAGS) \
$(WARN_CFLAGS)
+AM_LDFLAGS = \
+ $(LIBEMPATHY_LIBS)
+
BUILT_SOURCES = \
empathy-marshal.h \
empathy-marshal.c \
@@ -30,9 +31,6 @@ libempathy_la_SOURCES = \
empathy-chandler.c empathy-chandler.h \
empathy-marshal-main.c
-libempathy_la_LIBADD = \
- $(EMPATHY_LIBS)
-
libempathy_includedir = $(includedir)/empathy/
%-marshal.h: %-marshal.list Makefile.am