aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am21
1 files changed, 0 insertions, 21 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 31e0ec8cc..7d790a81a 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -19,9 +19,6 @@ AM_CPPFLAGS = \
$(DISABLE_DEPRECATED)
BUILT_SOURCES = \
- empathy-gtk-marshal.h \
- empathy-gtk-marshal.c \
- empathy-gtk-marshal.list \
empathy-gtk-enum-types.h \
empathy-gtk-enum-types.c
@@ -216,24 +213,6 @@ ui_DATA = \
empathy-search-bar.ui \
empathy-individual-widget.ui
-empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
- $(AM_V_GEN)( cd $(srcdir) && \
- sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
- $(libempathy_gtk_la_SOURCES) ) \
- | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
- @if cmp -s $@.tmp $@; then \
- rm $@.tmp; \
- else \
- mv $@.tmp $@; \
- fi
-
-%-marshal.h: %-marshal.list Makefile
- $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
- $(AM_V_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
- $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
$(AM_V_GEN)true
stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)