aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 2065589e3..210b6d4b0 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -1,3 +1,5 @@
+include $(top_srcdir)/tools/shave.mk
+
AM_CPPFLAGS = \
-I. \
-I$(top_srcdir) \
@@ -133,7 +135,7 @@ ui_DATA = \
empathy-new-message-dialog.ui
empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
- ( cd $(srcdir) && \
+ $(QUIET_GEN)( cd $(srcdir) && \
sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
$(libempathy_gtk_la_SOURCES) ) \
| sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
@@ -144,16 +146,16 @@ empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
fi
%-marshal.h: %-marshal.list Makefile
- $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+ $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
%-marshal.c: %-marshal.list Makefile
- echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+ $(QUIET_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
$(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
- @true
+ $(QUIET_GEN)true
stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
- (cd $(srcdir) \
+ $(QUIET_GEN)(cd $(srcdir) \
&& glib-mkenums \
--fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
--fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -170,7 +172,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
&& echo timestamp > $(@F)
empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
- (cd $(srcdir) \
+ $(QUIET_GEN)(cd $(srcdir) \
&& glib-mkenums \
--fhead "#include <config.h>\n" \
--fhead "#include <glib-object.h>\n" \