aboutsummaryrefslogtreecommitdiffstats
path: root/libempathy-gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libempathy-gtk/Makefile.am')
-rw-r--r--libempathy-gtk/Makefile.am33
1 files changed, 25 insertions, 8 deletions
diff --git a/libempathy-gtk/Makefile.am b/libempathy-gtk/Makefile.am
index 80c9a792d..2a4438e57 100644
--- a/libempathy-gtk/Makefile.am
+++ b/libempathy-gtk/Makefile.am
@@ -10,6 +10,7 @@ AM_CPPFLAGS = \
$(ENCHANT_CFLAGS) \
$(LIBCHAMPLAIN_CFLAGS) \
$(GEOCLUE_CFLAGS) \
+ $(WEBKIT_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED)
@@ -73,6 +74,7 @@ libempathy_gtk_la_LIBADD = \
$(ENCHANT_LIBS) \
$(LIBCHAMPLAIN_LIBS) \
$(GEOCLUE_LIBS) \
+ $(WEBKIT_LIBS) \
$(top_builddir)/libempathy/libempathy.la
libempathy_gtk_la_LDFLAGS = \
@@ -118,14 +120,6 @@ libempathy_gtk_headers = \
empathy-theme-manager.h \
empathy-ui-utils.h
-if HAVE_GEOCLUE
-libempathy_gtk_handwritten_source += \
- empathy-location-manager.c
-
-libempathy_gtk_headers += \
- empathy-location-manager.h
-endif
-
check_c_sources = \
$(libempathy_gtk_handwritten_source) \
$(libempathy_gtk_headers)
@@ -218,6 +212,29 @@ pkgconfig_DATA = libempathy-gtk.pc
EXTRA_DIST = \
$(ui_DATA)
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source += \
+ empathy-location-manager.c
+
+libempathy_gtk_headers += \
+ empathy-location-manager.h
+else
+EXTRA_DIST += \
+ empathy-location-manager.c \
+ empathy-location-manager.h
+endif
+
+if HAVE_WEBKIT
+libempathy_gtk_handwritten_source += \
+ empathy-theme-adium.c
+libempathy_gtk_headers += \
+ empathy-theme-adium.h
+else
+EXTRA_DIST += \
+ empathy-theme-adium.c \
+ empathy-theme-adium.h
+endif
+
CLEANFILES = \
$(BUILT_SOURCES) \
stamp-empathy-gtk-enum-types.h