aboutsummaryrefslogtreecommitdiffstats
path: root/extensions/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extensions/Makefile.am')
-rw-r--r--extensions/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/extensions/Makefile.am b/extensions/Makefile.am
index 7182734a8..e37b2af33 100644
--- a/extensions/Makefile.am
+++ b/extensions/Makefile.am
@@ -60,10 +60,9 @@ XSLTPROCFLAGS = --nonet --novalid
# Generated files which can be generated for all categories simultaneously
-_gen/all.xml: all.xml $(wildcard *.xml)
+_gen/all.xml: all.xml $(wildcard *.xml) $(tools_dir)/xincludator.py
@$(mkdir_p) _gen
- $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) --xinclude $(tools_dir)/identity.xsl \
- $< > $@
+ $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py $< > $@
extensions.html: _gen/all.xml $(tools_dir)/doc-generator.xsl
$(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) \
@@ -96,7 +95,7 @@ _gen/enums.h: _gen/all.xml \
$(tools_dir)/c-constants-gen.py
$(AM_V_GEN)$(PYTHON) $(tools_dir)/c-constants-gen.py \
Emp \
- $< > $@
+ $< _gen/enums
_gen/interfaces-body.h _gen/interfaces.h: _gen/all.xml \
$(tools_dir)/glib-interfaces-gen.py
@@ -107,10 +106,9 @@ _gen/interfaces-body.h _gen/interfaces.h: _gen/all.xml \
# subclass you want to use with --subclass will need to have its own category,
# although you can subdivide further if you want.
-_gen/misc.xml: misc.xml $(wildcard *.xml)
+_gen/misc.xml: misc.xml $(wildcard *.xml) $(tools_dir)/xincludator.py
@$(mkdir_p) _gen
- $(AM_V_GEN)$(XSLTPROC) $(XSLTPROCFLAGS) --xinclude $(tools_dir)/identity.xsl \
- $< > $@
+ $(AM_V_GEN)$(PYTHON) $(tools_dir)/xincludator.py $< > $@
_gen/cli-misc-body.h _gen/cli-misc.h: _gen/misc.xml \
$(tools_dir)/glib-client-gen.py