aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index f3da574ae..a2be750cf 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -15,6 +15,13 @@ gsettings_SCHEMAS = $(gsettings_files:.xml.in=.xml)
@INTLTOOL_XML_NOMERGE_RULE@
@GSETTINGS_RULES@
+# We need to compile schemas at make time
+# to run from source tree
+gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
+ $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
+
+all-local: gschemas.compiled
+
convertdir = $(datarootdir)/GConf/gsettings
convert_DATA = \
empathy.convert
@@ -82,4 +89,5 @@ DISTCLEANFILES = \
$(schemas_DATA) \
$(servicefile_DATA) \
$(gsettings_SCHEMAS) \
+ gschemas.compiled \
$(NULL)