aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
new file mode 100644
index 000000000..0f2e1b074
--- /dev/null
+++ b/data/Makefile.am
@@ -0,0 +1,27 @@
+SUBDIRS = 16x16
+
+profiledir = $(datadir)/mission-control/profiles
+profile_DATA = \
+ jabber.profile \
+ gtalk.profile \
+ salut.profile \
+ msn.profile
+
+gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+
+install-data-hook: update-icon-cache
+uninstall-hook: update-icon-cache
+update-icon-cache:
+ @-if test -z "$(DESTDIR)"; then \
+ echo "Updating Gtk icon cache."; \
+ $(gtk_update_icon_cache); \
+ else \
+ echo "*** Icon cache not updated. After (un)install, run this:"; \
+ echo "*** $(gtk_update_icon_cache)"; \
+ fi
+
+EXTRA_DIST = \
+ $(image_DATA) \
+ $(profile_DATA)
+
+