aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 443cdeba4..f3da574ae 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -22,11 +22,15 @@ convert_DATA = \
servicefiledir = $(datadir)/dbus-1/services
servicefile_in_files = \
org.freedesktop.Telepathy.Client.Empathy.Chat.service.in \
- org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in \
org.freedesktop.Telepathy.Client.Empathy.Auth.service.in \
org.freedesktop.Telepathy.Client.Empathy.Call.service.in \
org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
+if HAVE_EMPATHY_AV
+servicefile_in_files += \
+ org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in
+endif
+
servicefile_DATA = $(servicefile_in_files:.service.in=.service)
org.freedesktop.Telepathy.Client.Empathy.Chat.service: org.freedesktop.Telepathy.Client.Empathy.Chat.service.in
@@ -47,11 +51,15 @@ org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service: org.freedesktop.T
clientfiledir = $(datarootdir)/telepathy/clients
clientfile_DATA = \
Empathy.Chat.client \
- Empathy.AudioVideo.client \
Empathy.Auth.client \
Empathy.Call.client \
Empathy.FileTransfer.client
+if HAVE_EMPATHY_AV
+clientfile_DATA += \
+ Empathy.AudioVideo.client
+endif
+
htmldir = $(datadir)/empathy
html_DATA = \
Template.html \