aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 5819434a2..f3da574ae 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -26,11 +26,19 @@ servicefile_in_files = \
org.freedesktop.Telepathy.Client.Empathy.Call.service.in \
org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
+if HAVE_EMPATHY_AV
+servicefile_in_files += \
+ org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in
+endif
+
servicefile_DATA = $(servicefile_in_files:.service.in=.service)
org.freedesktop.Telepathy.Client.Empathy.Chat.service: org.freedesktop.Telepathy.Client.Empathy.Chat.service.in
$(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
+org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service: org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service.in
+ $(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
+
org.freedesktop.Telepathy.Client.Empathy.Auth.service: org.freedesktop.Telepathy.Client.Empathy.Auth.service.in
$(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
@@ -47,6 +55,11 @@ clientfile_DATA = \
Empathy.Call.client \
Empathy.FileTransfer.client
+if HAVE_EMPATHY_AV
+clientfile_DATA += \
+ Empathy.AudioVideo.client
+endif
+
htmldir = $(datadir)/empathy
html_DATA = \
Template.html \