aboutsummaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index 06f7e87a6..a39621f35 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -25,9 +25,29 @@ autostart_in_files = empathy.desktop.in
autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
+schemasdir = $(GCONF_SCHEMA_FILE_DIR)
+schemas_in_files = empathy.schemas.in
+schemas_DATA = $(schemas_in_files:.schemas.in=.schemas)
+@INTLTOOL_SCHEMAS_RULE@
+
+if GCONF_SCHEMAS_INSTALL
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schemas_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+ done \
+ fi
+else
+install-data-local:
+endif
+
EXTRA_DIST = \
$(image_DATA) \
$(autostart_DATA) \
- $(profile_DATA)
+ $(profile_DATA) \
+ $(schemas_in_files) \
+ $(schemas_DATA)
+DISTCLEANFILES = \
+ $(schemas_DATA)