aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a72c6f7ad..241fedfdc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -233,6 +233,16 @@ else
if test "x$have_nm" = "xyes"; then
AC_DEFINE(HAVE_NM, 1, [Define if you have libnm-glib])
have_connman=no
+ else
+ PKG_CHECK_MODULES(NETWORK_MANAGER,
+ [
+ libnm-glib >= $NETWORK_MANAGER_REQUIRED
+ ], have_nm="yes", have_nm="no")
+
+ if test "x$have_nm" = "xyes"; then
+ AC_DEFINE(HAVE_NM, 1, [Define if you have libnm-glib])
+ have_connman=no
+ fi
fi
fi