aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac100
1 files changed, 20 insertions, 80 deletions
diff --git a/configure.ac b/configure.ac
index 6f1bc2a99..3395c4148 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,8 +2,8 @@ dnl If not 1, append datestamp to the version number
m4_define(empathy_released, 0)
m4_define([empathy_major_version], [3])
-m4_define([empathy_minor_version], [10])
-m4_define([empathy_micro_version], [2])
+m4_define([empathy_minor_version], [11])
+m4_define([empathy_micro_version], [1])
m4_define([empathy_nano_version], [0])
dnl Display the nano_version only if it's not '0'
@@ -57,6 +57,10 @@ AC_DEFINE(TP_VERSION_MAX_ALLOWED, TP_VERSION_0_20, [Prevent post 0.20 APIs])
AC_DEFINE(TP_SEAL_ENABLE, 1, [Prevent to use sealed variables])
AC_DEFINE(TP_DISABLE_SINGLE_INCLUDE, 1, [Disable single include header])
+COGL_REQUIRED=1.14
+AC_DEFINE(COGL_VERSION_MIN_REQUIRED, COGL_VERSION_1_14, [Ignore post 1.14 deprecations])
+AC_DEFINE(COGL_VERSION_MAX_ALLOWED, COGL_VERSION_1_14, [Ignore post 1.14 deprecations])
+
GSTREAMER_REQUIRED=0.10.32
TP_FS_REQUIRED=0.6.0
LIBSECRET_REQUIRED=0.5
@@ -80,10 +84,6 @@ LIBACCOUNTS_REQUIRED=1.4
LIBSIGNON_REQUIRED=1.8
MC_PLUGINS_REQUIRED=5.13.1
-COGL_REQUIRED=1.14
-AC_DEFINE(COGL_VERSION_MIN_REQUIRED, COGL_VERSION_1_14, [Ignore post 1.14 deprecations])
-AC_DEFINE(COGL_VERSION_MAX_ALLOWED, COGL_VERSION_1_14, [Ignore post 1.14 deprecations])
-
# Use --enable-maintainer-mode to disable deprecated symbols,
# disable single include and enable GSEAL. If this is not a released empathy,
# maintainer mode is forced
@@ -126,7 +126,7 @@ AM_SILENT_RULES([yes])
# Check for programs
AC_PROG_CC
AC_HEADER_STDC
-AM_PROG_MKDIR_P
+AC_PROG_MKDIR_P
AM_PATH_GLIB_2_0
AC_PATH_XTRA
@@ -239,51 +239,18 @@ PKG_CHECK_MODULES(EMPATHY,
# -----------------------------------------------------------
# GStreamer
# -----------------------------------------------------------
-AC_ARG_ENABLE(gst-1.0,
- AS_HELP_STRING([--enable-gst-1.0=@<:@no/yes/auto@:>@],
- [build with GStreamer 1.0]),
- enable_gst1=$enableval,
- enable_gst1=auto)
-
-# Try to use GStreamer 1.0 if available
-have_gst1="no"
-if test "x$enable_gst1" != "xno"; then
- PKG_CHECK_MODULES(EMPATHY_CALL,
- [
- farstream-0.2
- telepathy-farstream >= $TP_FS_REQUIRED
- clutter-1.0 >= $CLUTTER_REQUIRED
- clutter-gtk-1.0 >= $CLUTTER_GTK_REQUIRED
- clutter-gst-2.0
- gstreamer-1.0
- gstreamer-audio-1.0
- gstreamer-video-1.0
- cogl-1.0 >= $COGL_REQUIRED
- ], have_gst1="yes", have_gst1="no")
-
- if test "x$have_gst1" = "xyes"; then
- AC_DEFINE(HAVE_GST1, 1, [Build with GStreamer 1.0])
- fi
-fi
-
-if test "x$enable_gst1" = "xyes" -a "x$have_gst1" != "xyes"; then
- AC_MSG_ERROR([Could not find GStreamer 1.0 dependencies:
-
-$EMPATHY_CALL_PKG_ERRORS])
-fi
-
-if test "x$have_gst1" != "xyes"; then
- PKG_CHECK_MODULES(EMPATHY_CALL,
- [
- farstream-0.1
- telepathy-farstream >= $TP_FS_REQUIRED
- clutter-1.0 >= $CLUTTER_REQUIRED
- clutter-gtk-1.0 >= $CLUTTER_GTK_REQUIRED
- clutter-gst-1.0 >= 1.5.2
- gstreamer-0.10 >= $GSTREAMER_REQUIRED
- gstreamer-interfaces-0.10
- ])
-fi
+PKG_CHECK_MODULES(EMPATHY_CALL,
+[
+ farstream-0.2
+ telepathy-farstream >= $TP_FS_REQUIRED
+ clutter-1.0 >= $CLUTTER_REQUIRED
+ clutter-gtk-1.0 >= $CLUTTER_GTK_REQUIRED
+ clutter-gst-2.0
+ gstreamer-1.0
+ gstreamer-audio-1.0
+ gstreamer-video-1.0
+ cogl-1.0 >= $COGL_REQUIRED
+])
AC_DEFINE(EMPATHY_GOA_PROVIDER, "org.gnome.OnlineAccounts",
[Name of provider for accounts imported from GOA])
@@ -479,31 +446,6 @@ AC_SUBST(GEOCODE_CFLAGS)
AC_SUBST(GEOCODE_LIBS)
# -----------------------------------------------------------
-# nautilus-sendto
-# -----------------------------------------------------------
-AC_ARG_ENABLE(nautilus-sendto,
- AS_HELP_STRING([--enable-nautilus-sendto=@<:@no/yes/auto@:>@],
- [build nautilus-sendto plugin]), ,
- enable_nautilus_sendto=auto)
-
-if test "x$enable_nautilus_sendto" != "xno"; then
- PKG_CHECK_MODULES(NST,
- [
- nautilus-sendto >= $NAUTILUS_SENDTO_REQUIRED
- ], have_nst="yes", have_nst="no")
-else
- have_nst=no
-fi
-
-if test "x$enable_nautilus_sendto" = "xyes" -a "x$have_nst" != "xyes"; then
- AC_MSG_ERROR([Could not find nautilus-sendto dependencies:
-
-$NST_PKG_ERRORS])
-fi
-
-AM_CONDITIONAL(HAVE_NST, test "x$have_nst" = "xyes")
-
-# -----------------------------------------------------------
# goa-mc-plugin
# -----------------------------------------------------------
AC_ARG_ENABLE(goa,
@@ -624,7 +566,7 @@ AM_CONDITIONAL(HAVE_UOA, test "x$have_uoa" = "xyes")
if test "x$have_uoa" = "xyes" -o "x$have_goa" = "xyes"; then
AC_MSG_CHECKING([Mission Control plugins dir])
- MISSION_CONTROL_PLUGINS_DIR=${libdir}/mission-control-plugins.`pkg-config --variable=MCP_ABI_VERSION mission-control-plugins`
+ MISSION_CONTROL_PLUGINS_DIR=`pkg-config --define-variable=libdir='${libdir}' --variable=plugindir mission-control-plugins`
AC_MSG_RESULT([$MISSION_CONTROL_PLUGINS_DIR])
AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
@@ -657,7 +599,6 @@ AC_CONFIG_FILES([
libempathy/Makefile
libempathy-gtk/Makefile
src/Makefile
- nautilus-sendto-plugin/Makefile
goa-mc-plugin/Makefile
ubuntu-online-accounts/Makefile
ubuntu-online-accounts/mc-plugin/Makefile
@@ -683,7 +624,6 @@ Configure summary:
Linker Flags................: ${LDFLAGS}
Prefix......................: ${prefix}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
- Use GStreamer 1.0...........: ${have_gst1}
Features:
Spell checking (enchant)....: ${have_enchant}