aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 0 insertions, 33 deletions
diff --git a/configure.ac b/configure.ac
index 8663fd79d..28040909b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -202,38 +202,6 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
AM_GLIB_GNU_GETTEXT
# -----------------------------------------------------------
-# Make CA certificates path configurable
-# Stolen from GIO's TLS
-# -----------------------------------------------------------
-AC_MSG_CHECKING([location of system Certificate Authority list])
-AC_ARG_WITH(ca-file,
- [AC_HELP_STRING([--with-ca-file=@<:@path@:>@],
- [path to system Certificate Authority list])])
-if test "$with_ca_file" = "no"; then
- AC_MSG_RESULT([disabled])
-else
- if test -z "$with_ca_file"; then
- for f in /etc/pki/tls/certs/ca-bundle.crt \
- /etc/ssl/certs/ca-certificates.crt; do
- if test -f "$f"; then
- with_ca_file="$f"
- fi
- done
- if test -z "$with_ca_file"; then
- AC_MSG_ERROR([could not find. Use --with-ca-file=path to set, or --without-ca-file to disable])
- fi
- fi
-
- AC_MSG_RESULT($with_ca_file)
- if ! test -f "$with_ca_file"; then
- AC_MSG_ERROR([No such file '$with_ca_file'. Use --with-ca-file=path to set, or --without-ca-file to disable])
- fi
- GTLS_SYSTEM_CA_FILE="$with_ca_file"
-
- AC_DEFINE_UNQUOTED([GTLS_SYSTEM_CA_FILE], ["$GTLS_SYSTEM_CA_FILE"], [path to system Certificate Authority list])
-fi
-
-# -----------------------------------------------------------
# Connectivity integration
# -----------------------------------------------------------
AC_ARG_WITH(connectivity,
@@ -530,7 +498,6 @@ Configure summary:
Compiler Flags..............: ${CFLAGS} ${ERROR_CFLAGS}
Prefix......................: ${prefix}
Coding style checks.........: ${ENABLE_CODING_STYLE_CHECKS}
- CA Cert Path................: ${GTLS_SYSTEM_CA_FILE}
Features:
Spell checking (enchant)....: ${have_enchant}