aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 33 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f9a89cf30..3a5dc72e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ m4_define(empathy_released, 0)
m4_define([empathy_major_version], [3])
m4_define([empathy_minor_version], [1])
-m4_define([empathy_micro_version], [90])
-m4_define([empathy_nano_version], [1])
+m4_define([empathy_micro_version], [91])
+m4_define([empathy_nano_version], [0])
dnl Display the nano_version only if it's not '0'
m4_define([empathy_base_version],
@@ -578,6 +578,35 @@ fi
AM_CONDITIONAL(HAVE_NST, test "x$have_nst" = "xyes")
+# -----------------------------------------------------------
+# goa-mc-plugin
+# -----------------------------------------------------------
+AC_ARG_ENABLE(goa,
+ AS_HELP_STRING([--enable-goa=@<:@no/yes/auto@:>@],
+ [build GOA MC plugin]), ,
+ enable_goa=auto)
+
+if test "x$enable_goa" != "xno"; then
+ PKG_CHECK_MODULES(GOA,
+ [
+ mission-control-plugins
+ goa-1.0
+ ], have_goa="yes", have_goa="no")
+
+ AC_MSG_CHECKING([Mission Control plugins dir])
+ MISSION_CONTROL_PLUGINS_DIR=`pkg-config --variable=plugindir mission-control-plugins`
+
+ AC_SUBST(MISSION_CONTROL_PLUGINS_DIR)
+else
+ have_goa=no
+fi
+
+if test "x$enable_goa" = "xyes" -a "x$have_goa" != "xyes"; then
+ AC_MSG_ERROR([Could not find GOA dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_GOA, test "x$have_goa" = "xyes")
+
# Optional dependency for avatar selection
AC_ARG_WITH([cheese],
AS_HELP_STRING([--with-cheese],
@@ -624,6 +653,7 @@ AC_CONFIG_FILES([
libempathy-gtk/Makefile
src/Makefile
nautilus-sendto-plugin/Makefile
+ goa-mc-plugin/Makefile
help/Makefile
tests/Makefile
tests/interactive/Makefile
@@ -656,6 +686,7 @@ Configure summary:
Extras:
Nautilus-sendto plugin......: ${have_nst}
+ GOA MC plugin...............: ${have_goa}
Salut E-D-S support.........: ${with_eds}
Exp. Call channel handler...: ${have_call}
Exp. Call log support.......: ${have_call_logs}