aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48e41bb5a..195589190 100644
--- a/configure.ac
+++ b/configure.ac
@@ -302,6 +302,15 @@ fi
AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
# -----------------------------------------------------------
+# Coding style checks
+# -----------------------------------------------------------
+AC_ARG_ENABLE(coding-style-checks,
+ AC_HELP_STRING([--disable-coding-style-checks],
+ [don't check coding style using grep]),
+ [ENABLE_CODING_STYLE_CHECKS=$enableval], [ENABLE_CODING_STYLE_CHECKS=yes])
+
+AC_SUBST([ENABLE_CODING_STYLE_CHECKS])
+# -----------------------------------------------------------
SHAVE_INIT(.)