aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac78
1 files changed, 46 insertions, 32 deletions
diff --git a/configure.ac b/configure.ac
index 7f6ec16dd..3aa266b93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ m4_define(empathy_released, 0)
m4_define([empathy_major_version], [3])
m4_define([empathy_minor_version], [1])
-m4_define([empathy_micro_version], [3])
+m4_define([empathy_micro_version], [5])
m4_define([empathy_nano_version], [0])
dnl Display the nano_version only if it's not '0'
@@ -19,10 +19,13 @@ m4_define(empathy_maybe_datestamp,
m4_define(empathy_version, empathy_full_version[]empathy_maybe_datestamp)
-AC_INIT(Empathy, empathy_version, http://bugzilla.gnome.org/browse.cgi?product=empathy)
+AC_INIT([Empathy],
+ [empathy_version],
+ [http://bugzilla.gnome.org/browse.cgi?product=empathy],
+ [empathy],
+ [https://live.gnome.org/Empathy])
-
-AC_PREREQ(2.59)
+AC_PREREQ([2.64])
AC_COPYRIGHT([
Copyright (C) 2003-2007 Imendio AB
Copyright (C) 2007-2010 Collabora Ltd.
@@ -31,7 +34,7 @@ AC_COPYRIGHT([
# Minimal version required
# Hardp deps
-FOLKS_REQUIRED=0.5.1
+FOLKS_REQUIRED=0.6.0
GLIB_REQUIRED=2.28.0
GNUTLS_REQUIRED=2.8.5
GTK_REQUIRED=3.0.2
@@ -77,23 +80,24 @@ AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([configure.ac])
AC_CONFIG_AUX_DIR(.)
-GNOME_COMMON_INIT
-
-AM_INIT_AUTOMAKE(1.9 dist-bzip2 no-define -Wno-portability)
+AM_INIT_AUTOMAKE([1.11 no-define -Wno-portability tar-ustar no-dist-gzip dist-xz])
-# Support silent build rules, requires at least automake-1.11. Disable
+# Support silent build rules. Disable
# by either passing --disable-silent-rules to configure or passing V=1
# to make
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+AM_SILENT_RULES([yes])
-AC_ISC_POSIX
+# Check for programs
AC_PROG_CC
AC_HEADER_STDC
-AM_PROG_LIBTOOL
AM_PROG_MKDIR_P
AM_PATH_GLIB_2_0
AC_PATH_XTRA
-IT_PROG_INTLTOOL([0.35.0])
+
+# Initialize libtool
+LT_PREREQ([2.2])
+LT_INIT
+
GNOME_DOC_INIT([0.17.3])
AC_PATH_PROG(DBUS_BINDING_TOOL, dbus-binding-tool)
GLIB_GSETTINGS
@@ -116,7 +120,8 @@ AS_COMPILER_FLAG(-Wall, ERROR_CFLAGS="-Wall", ERROR_CFLAGS="")
AS_COMPILER_FLAG(-Werror, werror=yes, werror=no)
AC_ARG_ENABLE(Werror,
- AC_HELP_STRING([--disable-Werror],[compile without -Werror (normally enabled in development builds)]),
+ AS_HELP_STRING([--disable-Werror],
+ [compile without -Werror (normally enabled in development builds)]),
werror=$enableval, :)
AS_COMPILER_FLAG(-Wextra, wextra=yes, wextra=no)
@@ -174,6 +179,8 @@ PKG_CHECK_MODULES(EMPATHY,
libcanberra-gtk3 >= $LIBCANBERRA_GTK_REQUIRED
libnotify >= $LIBNOTIFY_REQUIRED
gcr-3 >= $GCR_REQUIRED
+ libpulse
+ libpulse-mainloop-glib
webkitgtk-3.0 >= $WEBKIT_REQUIRED
])
@@ -188,11 +195,11 @@ PKG_CHECK_MODULES(EMPATHY_AV,
# -----------------------------------------------------------
# Call interface
# -----------------------------------------------------------
-AC_ARG_WITH(call,
- AC_HELP_STRING([--enable-call=@<:@no/yes/auto@:>@],
+AC_ARG_ENABLE(call,
+ AS_HELP_STRING([--enable-call=@<:@no/yes/auto@:>@],
[build with Call interface support]),,
- [with_call=auto])
-if test "x$with_call" != "xno" ; then
+ [enable_call=auto])
+if test "x$enable_call" != "xno" ; then
PKG_CHECK_MODULES(EMPATHY_CALL,
[
farsight2-0.10
@@ -209,7 +216,7 @@ else
have_call=no
fi
-if test "x$with_call" = "xyes" -a "x$have_call" != "xyes"; then
+if test "x$enable_call" = "xyes" -a "x$have_call" != "xyes"; then
AC_MSG_ERROR([Could not find Call handler dependencies.])
fi
AM_CONDITIONAL(HAVE_CALL, test "x$have_call" = "xyes")
@@ -218,11 +225,11 @@ AM_CONDITIONAL(HAVE_CALL, test "x$have_call" = "xyes")
# -----------------------------------------------------------
# Call support in tp-logger
# -----------------------------------------------------------
-AC_ARG_WITH(call-logs,
- AC_HELP_STRING([--enable-call-logs=@<:@no/yes/auto@:>@],
+AC_ARG_ENABLE(call-logs,
+ AS_HELP_STRING([--enable-call-logs=@<:@no/yes/auto@:>@],
[build with call logs support]),,
- [with_call_logs=auto])
-if test "x$with_call_logs" != "xno" ; then
+ [enable_call_logs=auto])
+if test "x$enable_call_logs" != "xno" ; then
SAVE_CFLAGS=$CFLAGS
SAVE_CPPFLAGS=$CPPFLAGS
CFLAGS="$CFLAGS $EMPATHY_CFLAGS"
@@ -241,7 +248,7 @@ else
have_call_logs=no
fi
-if test "x$with_call_logs" = "xyes" -a "x$have_call_logs" != "xyes"; then
+if test "x$enable_call_logs" = "xyes" -a "x$have_call_logs" != "xyes"; then
AC_MSG_ERROR([Call logs support requested but telepathy-logger wasn't
built with --enable-call])
fi
@@ -250,7 +257,8 @@ fi
# evolution-data-server (about-me)
# -----------------------------------------------------------
AC_ARG_WITH(eds,
- AC_HELP_STRING([--with-eds], [build with evolution-data-server support]),,
+ AS_HELP_STRING([--with-eds],
+ [build with evolution-data-server support]),,
[with_eds=yes])
if test x"$with_eds" = x"yes" ; then
PKG_CHECK_MODULES(EDS, [libebook-1.2])
@@ -262,7 +270,8 @@ fi
# -----------------------------------------------------------
AC_ARG_ENABLE(debug,
- AC_HELP_STRING([--disable-debug],[compile without debug code]),
+ AS_HELP_STRING([--disable-debug],
+ [compile without debug code]),
enable_debug=$enableval, enable_debug=yes )
if test x$enable_debug = xyes; then
@@ -272,13 +281,15 @@ fi
# -----------------------------------------------------------
# Language Support
# -----------------------------------------------------------
+IT_PROG_INTLTOOL([0.40.0])
+
+AM_GNU_GETTEXT_VERSION([0.17])
+AM_GNU_GETTEXT([external])
GETTEXT_PACKAGE=empathy
AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
-AM_GLIB_GNU_GETTEXT
-
# -----------------------------------------------------------
# Connectivity integration
# -----------------------------------------------------------
@@ -570,7 +581,8 @@ AC_SUBST(CONTROL_CENTER_EMBEDDING_LIBS)
# Optional dependency for avatar selection
AC_ARG_WITH([cheese],
- AS_HELP_STRING([--with-cheese], [enable cheese webcam support]),,
+ AS_HELP_STRING([--with-cheese],
+ [enable cheese webcam support]),,
with_cheese=auto)
if test x"$with_cheese" != x"no" ; then
@@ -591,14 +603,15 @@ AM_CONDITIONAL(BUILD_CHEESE, test x${have_cheese} = xyes)
# Coding style checks
# -----------------------------------------------------------
AC_ARG_ENABLE(coding-style-checks,
- AC_HELP_STRING([--disable-coding-style-checks],
+ AS_HELP_STRING([--disable-coding-style-checks],
[do not check coding style using grep]),
- [ENABLE_CODING_STYLE_CHECKS=$enableval], [ENABLE_CODING_STYLE_CHECKS=yes])
+ [ENABLE_CODING_STYLE_CHECKS=$enableval],
+ [ENABLE_CODING_STYLE_CHECKS=yes])
AC_SUBST([ENABLE_CODING_STYLE_CHECKS])
# -----------------------------------------------------------
-AC_OUTPUT([
+AC_CONFIG_FILES([
Makefile
data/Makefile
data/empathy.desktop.in
@@ -616,6 +629,7 @@ AC_OUTPUT([
tests/xml/Makefile
tools/Makefile
])
+AC_OUTPUT
echo "
Configure summary: