aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac99
1 files changed, 5 insertions, 94 deletions
diff --git a/configure.ac b/configure.ac
index 33bbf466a..9aab250b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,9 +2,9 @@ dnl If not 1, append datestamp to the version number
m4_define(empathy_released, 0)
m4_define([empathy_major_version], [3])
-m4_define([empathy_minor_version], [4])
+m4_define([empathy_minor_version], [5])
m4_define([empathy_micro_version], [0])
-m4_define([empathy_nano_version], [2])
+m4_define([empathy_nano_version], [0])
dnl Display the nano_version only if it's not '0'
m4_define([empathy_base_version],
@@ -37,9 +37,9 @@ AC_COPYRIGHT([
FOLKS_REQUIRED=0.6.6
GNUTLS_REQUIRED=2.8.5
-GLIB_REQUIRED=2.30.0
+GLIB_REQUIRED=2.32.0
AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_30, [Ignore post 2.30 deprecations])
-AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_30, [Prevent post 2.30 APIs])
+AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_32, [Prevent post 2.32 APIs])
GTK_REQUIRED=3.3.6
AC_DEFINE(GDK_VERSION_MIN_REQUIRED, GDK_VERSION_3_4, [Ignore post 3.4 deprecations])
@@ -58,7 +58,7 @@ GCR_REQUIRED=2.91.4
LIBCANBERRA_GTK_REQUIRED=0.25
LIBNOTIFY_REQUIRED=0.7.0
TELEPATHY_FARSTREAM_REQUIRED=0.2.1
-TELEPATHY_GLIB_REQUIRED=0.17.5
+TELEPATHY_GLIB_REQUIRED=0.17.6
TELEPATHY_LOGGER=0.2.13
WEBKIT_REQUIRED=1.3.13
GOA_REQUIRED=3.3.0
@@ -266,58 +266,6 @@ AC_SUBST(GETTEXT_PACKAGE)
AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
# -----------------------------------------------------------
-# Connectivity integration
-# -----------------------------------------------------------
-AC_ARG_WITH(connectivity,
- AS_HELP_STRING([--with-connectivity=@<:@nm/connman/auto/no@:>@],
- [build with connectivity support]), ,
- with_connectivity=auto)
-
-if test "x$with_connectivity" = "xno"; then
- have_nm=no
- have_connman=no
-
-elif test "x$with_connectivity" = "xconnman"; then
- have_nm=no
-
- PKG_CHECK_MODULES(CONNMAN,
- [
- dbus-glib-1
- ], have_connman="yes", have_connman="no")
-
- if test "x$have_connman" = "xyes"; then
- AC_DEFINE(HAVE_CONNMAN, 1, [Define if you have connman dependencies])
- fi
-
-else
- have_connman=no
-
- PKG_CHECK_MODULES(NETWORK_MANAGER,
- [
- libnm-glib >= $NETWORK_MANAGER_REQUIRED
- ], have_nm="yes", have_nm="no")
-
- if test "x$have_nm" = "xyes"; then
- AC_DEFINE(HAVE_NM, 1, [Define if you have libnm-glib])
- fi
-fi
-
-if test "x$with_connectivity" = "xconnman" -a "x$have_connman" != "xyes"; then
- AC_MSG_ERROR([Couldn't find connman dependencies:
-
-$CONNMAN_PKG_ERRORS])
-fi
-
-if test "x$with_connectivity" = "xnm" -a "x$have_nm" != "xyes"; then
- AC_MSG_ERROR([Couldn't find Network Manager dependencies:
-
-$NETWORK_MANAGER_PKG_ERRORS])
-fi
-
-AM_CONDITIONAL(HAVE_NM, test "x$have_nm" = "xyes")
-AM_CONDITIONAL(HAVE_CONNMAN, test "x$have_connman" = "xyes")
-
-# -----------------------------------------------------------
# gudev
# -----------------------------------------------------------
AC_ARG_ENABLE(gudev,
@@ -479,38 +427,6 @@ AC_SUBST(GEOCODE_CFLAGS)
AC_SUBST(GEOCODE_LIBS)
# -----------------------------------------------------------
-# meego widgets support
-# -----------------------------------------------------------
-AC_ARG_ENABLE(meego,
- AS_HELP_STRING([--enable-meego=@<:@no/yes@:>@],
- [Enable meego widgets]), ,
- enable_meego=no)
-
-if test "x$enable_meego" != "xno"; then
- PKG_CHECK_MODULES(MEEGO,
- [
- mx-gtk-1.0
- gio-unix-2.0
- ], have_meego="yes", have_meego="no")
-
- if test "x$have_meego" = "xyes"; then
- AC_DEFINE(HAVE_MEEGO, 1, [Define if you have meego])
- fi
-else
- have_meego="no"
-fi
-
-if test "x$enable_meego" = "xyes" -a "x$have_meego" != "xyes"; then
- AC_MSG_ERROR([Could not find meego dependencies:
-
-$MEEGO_PKG_ERRORS])
-fi
-
-AM_CONDITIONAL(HAVE_MEEGO, test "x$have_meego" = "xyes")
-AC_SUBST(MEEGO_CFLAGS)
-AC_SUBST(MEEGO_LIBS)
-
-# -----------------------------------------------------------
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
@@ -640,14 +556,9 @@ Configure summary:
Display maps (libchamplain).: ${have_libchamplain}
Location awareness (Geoclue): ${have_geoclue}
Geocode support (Geocode)...: ${have_geocode}
- Meego widgets...............: ${have_meego}
Cheese webcam support ......: ${have_cheese}
Camera monitoring...........: ${have_gudev}
- Connectivity:
- NetworkManager integration..: ${have_nm}
- ConnMan integration.........: ${have_connman}
-
Extras:
Nautilus-sendto plugin......: ${have_nst}
GOA MC plugin...............: ${have_goa}