aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 35 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 3484e3cd3..bc0491cae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -157,14 +157,31 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
AM_GLIB_GNU_GETTEXT
# -----------------------------------------------------------
-# NM integration
+# Connectivity integration
# -----------------------------------------------------------
-AC_ARG_ENABLE(network-manager,
- AS_HELP_STRING([--enable-network-manager=@<:@no/yes/auto@:>@],
- [build with network-manager support]), ,
- enable_network_manager=auto)
+AC_ARG_WITH(connectivity,
+ AS_HELP_STRING([--with-connectivity=@<:@nm/connman/auto/no@:>@],
+ [build with connectivity support]), ,
+ with_connectivity=auto)
+
+if test "x$with_connectivity" = "xno"; then
+ have_nm=no
+ have_connman=no
+
+elif test "x$with_connectivity" = "xconnman"; then
+
+ PKG_CHECK_MODULES(CONNMAN,
+ [
+ dbus-glib-1
+ ], have_connman="yes", have_connman="no")
+
+ if test "x$have_connman" = "xyes"; then
+ AC_DEFINE(HAVE_CONNMAN, 1, [Define if you have connman dependencies])
+ have_nm=no
+ fi
+
+else
-if test "x$enable_network_manager" != "xno"; then
PKG_CHECK_MODULES(NETWORK_MANAGER,
[
libnm_glib >= $NETWORK_MANAGER_REQUIRED
@@ -172,15 +189,20 @@ if test "x$enable_network_manager" != "xno"; then
if test "x$have_nm" = "xyes"; then
AC_DEFINE(HAVE_NM, 1, [Define if you have libnm-glib])
+ have_connman=no
fi
-else
- have_nm=no
fi
-if test "x$enable_network_manager" = "xyes" -a "x$have_nm" != "xyes"; then
+if test "x$with_connectivity" = "xconnman" -a "x$have_connman" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find connman dependencies.])
+fi
+
+if test "x$with_connectivity" = "xnm" -a "x$have_nm" != "xyes"; then
AC_MSG_ERROR([Couldn't find libnm-glib dependencies.])
fi
-AM_CONDITIONAL(HAVE_NM, test "x$have_NM" = "xyes")
+
+AM_CONDITIONAL(HAVE_NM, test "x$have_nm" = "xyes")
+AM_CONDITIONAL(HAVE_CONNMAN, test "x$have_connman" = "xyes")
# -----------------------------------------------------------
# Webkit
@@ -479,7 +501,10 @@ Configure summary:
Display maps (libchamplain).: ${have_libchamplain}
Location awareness (Geoclue): ${have_geoclue}
Adium themes (Webkit).......: ${have_webkit}
+
+ Connectivity:
NetworkManager integration..: ${have_nm}
+ ConnMan integration.........: ${have_connman}
Extras:
Documentation...............: ${enable_gtk_doc}