aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 32 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e32b4ca54..952ff13cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,8 +3,8 @@ m4_define(empathy_released, 0)
m4_define([empathy_major_version], [2])
m4_define([empathy_minor_version], [29])
-m4_define([empathy_micro_version], [91])
-m4_define([empathy_nano_version], [2])
+m4_define([empathy_micro_version], [92])
+m4_define([empathy_nano_version], [0])
dnl Display the nano_version only if it's not '0'
m4_define([empathy_base_version],
@@ -442,6 +442,7 @@ if test "x$enable_meego" != "xno"; then
if test "x$have_meego" = "xyes"; then
AC_DEFINE(HAVE_MEEGO, 1, [Define if you have meego])
+ chain_enable_favourite_contacts="yes"
fi
else
have_meego="no"
@@ -456,6 +457,34 @@ AC_SUBST(MEEGO_CFLAGS)
AC_SUBST(MEEGO_LIBS)
# -----------------------------------------------------------
+# favourite contacts support
+# -----------------------------------------------------------
+AC_ARG_ENABLE(favourite_contacts,
+ AS_HELP_STRING([--enable-favourite-contacts=@<:no/yes@:>@],
+ [Enable favourite contacts]), ,
+ enable_favourite_contacts=no)
+
+if test "x$enable_favourite_contacts" != "xno" -o "x$chain_enable_favourite_contacts" == "xyes"; then
+ PKG_CHECK_MODULES(TELEPATHY_LOGGER,
+ [
+ telepathy-logger
+ ], have_telepathy_logger="yes", have_telepathy_logger="no")
+
+ if test "x$have_telepathy_logger" = "xyes"; then
+ have_favourite_contacts="yes"
+ AC_DEFINE(HAVE_FAVOURITE_CONTACTS, 1, [Define if you want favourite contacts support])
+ fi
+else
+ have_favourite_contacts="no"
+fi
+
+if test "x$enable_favourite_contacts" = "xyes" -a "x$have_favourite_contacts" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find favourite contacts dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_FAVOURITE_CONTACTS, test "x$have_telepathy_logger" = "xyes")
+
+# -----------------------------------------------------------
# nautilus-sendto
# -----------------------------------------------------------
AC_ARG_ENABLE(nautilus-sendto,
@@ -551,6 +580,7 @@ Configure summary:
Location awareness (Geoclue): ${have_geoclue}
Adium themes (Webkit).......: ${have_webkit}
Meego widgets ..............: ${have_meego}
+ Favourite contacts .........: ${have_favourite_contacts}
Control center embedding....: ${have_control_center_embedding}
Logging: