aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8a85a7525..9ff98e6e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,29 @@ AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE",[Gettext package name])
AM_GLIB_GNU_GETTEXT
# -----------------------------------------------------------
+# Webkit
+# -----------------------------------------------------------
+AC_ARG_ENABLE(webkit,
+ AS_HELP_STRING([--enable-webkit=@<:@no/yes/auto@:>@],
+ [build with webkit support]), ,
+ enable_webkit=auto)
+
+if test "x$enable_webkit" != "xno"; then
+ PKG_CHECK_MODULES(WEBKIT,
+ [
+ WebKitGtk
+ ], have_webkit="yes", have_webkit="no")
+else
+ have_webkit=no
+fi
+
+if test "x$enable_webkit" = "xyes" -a "x$have_webkit" != "xyes"; then
+ AC_MSG_ERROR([Couldn't find webkit dependencies.])
+fi
+
+AM_CONDITIONAL(HAVE_WEBKIT, test "x$have_webkit" = "xyes")
+
+# -----------------------------------------------------------
# spellchecking checks: enchant and iso-codes
# -----------------------------------------------------------
AC_ARG_ENABLE(spell,