aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 16 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f3fe46945..9fd3a1c36 100644
--- a/configure.ac
+++ b/configure.ac
@@ -251,6 +251,20 @@ fi
AM_CONDITIONAL(HAVE_PYTHON, test "x$have_python" = "xyes")
dnl -----------------------------------------------------------
+dnl VoIP support
+dnl -----------------------------------------------------------
+AC_ARG_ENABLE(voip,
+ AS_HELP_STRING([--enable-voip=@<:@no/yes@:>@],
+ [Add support for Voice and Video call]), ,
+ enable_voip=no)
+
+if test "x$enable_voip" = "xyes"; then
+ AC_DEFINE(HAVE_VOIP, 1, [Define if we have voip])
+fi
+
+AM_CONDITIONAL(HAVE_VOIP, test "x$enable_voip" = "xyes")
+
+dnl -----------------------------------------------------------
AC_OUTPUT([
Makefile
@@ -273,7 +287,8 @@ AC_OUTPUT([
megaphone/data/Makefile
nothere/Makefile
nothere/src/Makefile
- nothere/data/Makefile doc/Makefile
+ nothere/data/Makefile
+ doc/Makefile
doc/libempathy/Makefile
doc/libempathy-gtk/Makefile
python/Makefile