aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ChangeLog6
-rw-r--r--configure.ac2
-rw-r--r--libempathy/empathy-log-manager.c4
3 files changed, 11 insertions, 1 deletions
diff --git a/ChangeLog b/ChangeLog
index c395899fe..4717a3b73 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,5 +1,11 @@
2007-09-21 Xavier Claessens <xclaesse@gmail.com>
+ * libempathy/empathy-log-manager.c: Ignore log files that don't have a
+ good filename. Fixes bug #462046 (Michael Scherer).
+ * configure.ac: Bump GLIB version to 2.14.0.
+
+2007-09-21 Xavier Claessens <xclaesse@gmail.com>
+
* doc/libempathy-gtk/Makefile.am: Explicitely use libempathy from
builddir. Fixes bug #478558 (Frederic Peters).
diff --git a/configure.ac b/configure.ac
index bade8bb30..92f5def93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,7 +45,7 @@ IT_PROG_INTLTOOL([0.35.0])
GTK_DOC_CHECK([1.3])
-GLIB_REQUIRED=2.12.0
+GLIB_REQUIRED=2.14.0
GTK_REQUIRED=2.12.0
GCONF_REQUIRED=1.2.0
LIBGLADE_REQUIRED=2.0.0
diff --git a/libempathy/empathy-log-manager.c b/libempathy/empathy-log-manager.c
index e47f50fb8..efdbae86b 100644
--- a/libempathy/empathy-log-manager.c
+++ b/libempathy/empathy-log-manager.c
@@ -263,6 +263,10 @@ empathy_log_manager_get_dates (EmpathyLogManager *manager,
continue;
}
+ if (!g_regex_match_simple ("\\d{8}", date, 0, 0)) {
+ continue;
+ }
+
dates = g_list_insert_sorted (dates, date, (GCompareFunc) strcmp);
}