aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--tests/Makefile.am2
-rw-r--r--tests/test-empathy-account-assistant.c25
2 files changed, 27 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7f99eaf36..eb5dba529 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,6 +25,7 @@ LDADD = \
noinst_PROGRAMS = \
contact-manager \
empetit \
+ test-empathy-account-assistant \
test-empathy-presence-chooser \
test-empathy-status-preset-dialog \
test-empathy-protocol-chooser
@@ -34,6 +35,7 @@ empetit_SOURCES = empetit.c
test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
+test_empathy_account_assistant_SOURCES = test-empathy-account-assistant.c
check_PROGRAMS = check-main
TESTS = check-main
diff --git a/tests/test-empathy-account-assistant.c b/tests/test-empathy-account-assistant.c
new file mode 100644
index 000000000..bdcbe6c69
--- /dev/null
+++ b/tests/test-empathy-account-assistant.c
@@ -0,0 +1,25 @@
+#include <config.h>
+
+#include <gtk/gtk.h>
+
+#include <libempathy-gtk/empathy-ui-utils.h>
+#include <libempathy-gtk/empathy-account-assistant.h>
+
+int main (int argc, char *argv)
+{
+ GtkWidget *assistant;
+
+ gtk_init (&argc, &argv);
+ empathy_gtk_init ();
+
+ assistant = empathy_account_assistant_new ();
+
+ gtk_widget_show_all (assistant);
+
+ g_signal_connect_swapped (assistant, "destroy",
+ G_CALLBACK (gtk_main_quit), NULL);
+
+ gtk_main ();
+
+ return 0;
+}