aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xautogen.sh14
-rw-r--r--configure.ac17
2 files changed, 30 insertions, 1 deletions
diff --git a/autogen.sh b/autogen.sh
index 9c091dc06..0e85e5cca 100755
--- a/autogen.sh
+++ b/autogen.sh
@@ -17,6 +17,18 @@ which gnome-autogen.sh || {
echo "You need to install gnome-common from the GNOME CVS"
exit 1
}
-USE_GNOME2_MACROS=1 USE_COMMON_DOC_BUILD=yes . gnome-autogen.sh
+# Fetch submodules if needed
+if test ! -f telepathy-yell/autogen.sh;
+then
+ echo "+ Setting up submodules"
+ git submodule init
+fi
+git submodule update
+
+# launch tp-yell's autogen.sh
+cd telepathy-yell
+sh autogen.sh --no-configure
+cd ..
+USE_GNOME2_MACROS=1 USE_COMMON_DOC_BUILD=yes . gnome-autogen.sh
diff --git a/configure.ac b/configure.ac
index 70d8e5b1e..413a24451 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,12 @@ NETWORK_MANAGER_REQUIRED=0.7.0
WEBKIT_REQUIRED=1.1.15
GNOME_CONTROL_CENTER_GTK3_REQUIRED=2.31.4
+# telepathy-yell
+prev_top_build_prefix=$ac_top_build_prefix
+AX_CONFIG_DIR([telepathy-yell])
+ac_top_build_prefix=$prev_top_build_prefix
+export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:"$ac_top_build_prefix"telepathy-yell/telepathy-yell
+
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_SRCDIR([configure.ac])
@@ -163,6 +169,17 @@ PKG_CHECK_MODULES(EMPATHY_AV,
])
# -----------------------------------------------------------
+# Call interface
+# -----------------------------------------------------------
+AC_ARG_WITH(call,
+ AC_HELP_STRING([--with-call], [build with Call interface support]),,
+ [with_call=yes])
+if test "x$with_call" = "xyes" ; then
+ PKG_CHECK_MODULES(YELL, [telepathy-yell])
+ AC_DEFINE(HAVE_CALL, 1, [Define if we have Call interface support])
+fi
+
+# -----------------------------------------------------------
# evolution-data-server (about-me)
# -----------------------------------------------------------
AC_ARG_WITH(eds,