aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--configure.ac3
-rw-r--r--libempathy-gtk/gcr-simple-certificate.c2
-rw-r--r--libempathy-gtk/gcr-simple-certificate.h2
3 files changed, 3 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 0a1b6ef56..69123b90f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -221,8 +221,7 @@ PKG_CHECK_MODULES(LIBNOTIFY,
PKG_CHECK_MODULES(UNIQUE, unique-1.0 >= $UNIQUE_REQUIRED)
# gnome-keyring breaks API in 2.91.x
PKG_CHECK_MODULES(GCR,
- gcr-0 >= $KEYRING_REQUIRED
- gcr-0 < 2.91)
+ gcr-0 >= $KEYRING_REQUIRED)
# Enable GSEAL checks if needed
if test "x$USE_MAINTAINER_MODE" = "xyes"; then
diff --git a/libempathy-gtk/gcr-simple-certificate.c b/libempathy-gtk/gcr-simple-certificate.c
index 072cbac97..dab1eef4d 100644
--- a/libempathy-gtk/gcr-simple-certificate.c
+++ b/libempathy-gtk/gcr-simple-certificate.c
@@ -119,7 +119,7 @@ gcr_certificate_iface (GcrCertificateIface *iface)
*/
GcrCertificate*
-gcr_simple_certificate_new (const guchar *data, gsize n_data)
+gcr_simple_certificate_new (gconstpointer data, gsize n_data)
{
GcrSimpleCertificate *cert;
diff --git a/libempathy-gtk/gcr-simple-certificate.h b/libempathy-gtk/gcr-simple-certificate.h
index ee46b4817..83014db6e 100644
--- a/libempathy-gtk/gcr-simple-certificate.h
+++ b/libempathy-gtk/gcr-simple-certificate.h
@@ -53,7 +53,7 @@ struct _GcrSimpleCertificateClass {
GType gcr_simple_certificate_get_type (void);
-GcrCertificate* gcr_simple_certificate_new (const guchar *data,
+GcrCertificate* gcr_simple_certificate_new (gconstpointer data,
gsize n_data);
G_END_DECLS