aboutsummaryrefslogtreecommitdiffstats
path: root/ubuntu-online-accounts/cc-plugins/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-09-06 15:49:10 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-09-06 16:59:52 +0800
commitb73b93e7cfb16579ef6ec18ef01acdac2c6c24f3 (patch)
treec677467f6ac3d093e590b3102f2b0cbb225b5aff /ubuntu-online-accounts/cc-plugins/Makefile.am
parent006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e (diff)
downloadgsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.tar
gsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.tar.gz
gsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.tar.bz2
gsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.tar.lz
gsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.tar.xz
gsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.tar.zst
gsoc2013-empathy-b73b93e7cfb16579ef6ec18ef01acdac2c6c24f3.zip
Move account plugins to their own dir
https://bugzilla.gnome.org/show_bug.cgi?id=683415
Diffstat (limited to 'ubuntu-online-accounts/cc-plugins/Makefile.am')
-rw-r--r--ubuntu-online-accounts/cc-plugins/Makefile.am228
1 files changed, 1 insertions, 227 deletions
diff --git a/ubuntu-online-accounts/cc-plugins/Makefile.am b/ubuntu-online-accounts/cc-plugins/Makefile.am
index b87b19c18..c8c3ce097 100644
--- a/ubuntu-online-accounts/cc-plugins/Makefile.am
+++ b/ubuntu-online-accounts/cc-plugins/Makefile.am
@@ -1,227 +1 @@
-# Generated using empathy/ubuntu-online-accounts/cc-plugins/generate-plugins.py
-# Do NOT edit manually
-SUBDIRS = providers services app-plugin
-
-plugindir = $(ACCOUNTS_PROVIDER_PLUGIN_DIR)
-
-INCLUDES = \
- -I$(top_builddir) \
- -I$(top_srcdir) \
- -DLOCALEDIR=\""$(datadir)/locale"\" \
- $(UOA_CFLAGS) \
- $(WARN_CFLAGS) \
- $(ERROR_CFLAGS) \
- $(DISABLE_DEPRECATED) \
- $(EMPATHY_CFLAGS)
-
-plugin_LTLIBRARIES = \
- libaim.la\
- libgadugadu.la\
- libgroupwise.la\
- libicq.la\
- libirc.la\
- libjabber.la\
- libmxit.la\
- libmyspace.la\
- libsip.la\
- liblocal-xmpp.la\
- libsametime.la\
- libyahoojp.la\
- libyahoo.la\
- libzephyr.la \
- $(NULL)
-
-libaim_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-aim.c \
- empathy-accounts-plugin-aim.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libaim_la_LDFLAGS = -module -avoid-version
-libaim_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libgadugadu_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-gadugadu.c \
- empathy-accounts-plugin-gadugadu.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libgadugadu_la_LDFLAGS = -module -avoid-version
-libgadugadu_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libgroupwise_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-groupwise.c \
- empathy-accounts-plugin-groupwise.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libgroupwise_la_LDFLAGS = -module -avoid-version
-libgroupwise_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libicq_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-icq.c \
- empathy-accounts-plugin-icq.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libicq_la_LDFLAGS = -module -avoid-version
-libicq_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libirc_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-irc.c \
- empathy-accounts-plugin-irc.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libirc_la_LDFLAGS = -module -avoid-version
-libirc_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libjabber_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-jabber.c \
- empathy-accounts-plugin-jabber.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libjabber_la_LDFLAGS = -module -avoid-version
-libjabber_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libmxit_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-mxit.c \
- empathy-accounts-plugin-mxit.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libmxit_la_LDFLAGS = -module -avoid-version
-libmxit_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libmyspace_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-myspace.c \
- empathy-accounts-plugin-myspace.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libmyspace_la_LDFLAGS = -module -avoid-version
-libmyspace_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libsip_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-sip.c \
- empathy-accounts-plugin-sip.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libsip_la_LDFLAGS = -module -avoid-version
-libsip_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-liblocal_xmpp_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-local-xmpp.c \
- empathy-accounts-plugin-local-xmpp.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-liblocal_xmpp_la_LDFLAGS = -module -avoid-version
-liblocal_xmpp_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libsametime_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-sametime.c \
- empathy-accounts-plugin-sametime.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libsametime_la_LDFLAGS = -module -avoid-version
-libsametime_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libyahoojp_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-yahoojp.c \
- empathy-accounts-plugin-yahoojp.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libyahoojp_la_LDFLAGS = -module -avoid-version
-libyahoojp_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libyahoo_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-yahoo.c \
- empathy-accounts-plugin-yahoo.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libyahoo_la_LDFLAGS = -module -avoid-version
-libyahoo_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
-
-
-libzephyr_la_SOURCES = \
- empathy-accounts-plugin.c \
- empathy-accounts-plugin.h \
- empathy-accounts-plugin-zephyr.c \
- empathy-accounts-plugin-zephyr.h \
- empathy-accounts-plugin-widget.c \
- empathy-accounts-plugin-widget.h
-libzephyr_la_LDFLAGS = -module -avoid-version
-libzephyr_la_LIBADD = \
- $(UOA_LIBS) \
- $(top_builddir)/libempathy/libempathy.la \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la
+SUBDIRS = account-plugins providers services app-plugin