aboutsummaryrefslogtreecommitdiffstats
path: root/ubuntu-online-accounts/cc-plugins/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-09-05 21:59:26 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-09-06 16:59:52 +0800
commit006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e (patch)
tree4054c13dc6918a992fa324355ea5d33c11c20f9a /ubuntu-online-accounts/cc-plugins/Makefile.am
parenta49a0e8b08ff8ad164304f0600b90178b0ff44c6 (diff)
downloadgsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.tar
gsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.tar.gz
gsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.tar.bz2
gsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.tar.lz
gsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.tar.xz
gsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.tar.zst
gsoc2013-empathy-006b27d7f0c5dd6efeee83e2c7bb21a60a7a138e.zip
Generate one GType per UOA protocol plugin
Each plugin now has its own GType inheriting from EmpathyAccountsPlugin which is cleaner. https://bugzilla.gnome.org/show_bug.cgi?id=683415
Diffstat (limited to 'ubuntu-online-accounts/cc-plugins/Makefile.am')
-rw-r--r--ubuntu-online-accounts/cc-plugins/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/ubuntu-online-accounts/cc-plugins/Makefile.am b/ubuntu-online-accounts/cc-plugins/Makefile.am
index 62bcf49f5..b87b19c18 100644
--- a/ubuntu-online-accounts/cc-plugins/Makefile.am
+++ b/ubuntu-online-accounts/cc-plugins/Makefile.am
@@ -34,6 +34,8 @@ plugin_LTLIBRARIES = \
libaim_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-aim.c \
+ empathy-accounts-plugin-aim.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libaim_la_LDFLAGS = -module -avoid-version
@@ -46,6 +48,8 @@ libaim_la_LIBADD = \
libgadugadu_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-gadugadu.c \
+ empathy-accounts-plugin-gadugadu.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libgadugadu_la_LDFLAGS = -module -avoid-version
@@ -58,6 +62,8 @@ libgadugadu_la_LIBADD = \
libgroupwise_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-groupwise.c \
+ empathy-accounts-plugin-groupwise.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libgroupwise_la_LDFLAGS = -module -avoid-version
@@ -70,6 +76,8 @@ libgroupwise_la_LIBADD = \
libicq_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-icq.c \
+ empathy-accounts-plugin-icq.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libicq_la_LDFLAGS = -module -avoid-version
@@ -82,6 +90,8 @@ libicq_la_LIBADD = \
libirc_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-irc.c \
+ empathy-accounts-plugin-irc.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libirc_la_LDFLAGS = -module -avoid-version
@@ -94,6 +104,8 @@ libirc_la_LIBADD = \
libjabber_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-jabber.c \
+ empathy-accounts-plugin-jabber.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libjabber_la_LDFLAGS = -module -avoid-version
@@ -106,6 +118,8 @@ libjabber_la_LIBADD = \
libmxit_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-mxit.c \
+ empathy-accounts-plugin-mxit.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libmxit_la_LDFLAGS = -module -avoid-version
@@ -118,6 +132,8 @@ libmxit_la_LIBADD = \
libmyspace_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-myspace.c \
+ empathy-accounts-plugin-myspace.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libmyspace_la_LDFLAGS = -module -avoid-version
@@ -130,6 +146,8 @@ libmyspace_la_LIBADD = \
libsip_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-sip.c \
+ empathy-accounts-plugin-sip.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libsip_la_LDFLAGS = -module -avoid-version
@@ -142,6 +160,8 @@ libsip_la_LIBADD = \
liblocal_xmpp_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-local-xmpp.c \
+ empathy-accounts-plugin-local-xmpp.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
liblocal_xmpp_la_LDFLAGS = -module -avoid-version
@@ -154,6 +174,8 @@ liblocal_xmpp_la_LIBADD = \
libsametime_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-sametime.c \
+ empathy-accounts-plugin-sametime.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libsametime_la_LDFLAGS = -module -avoid-version
@@ -166,6 +188,8 @@ libsametime_la_LIBADD = \
libyahoojp_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-yahoojp.c \
+ empathy-accounts-plugin-yahoojp.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libyahoojp_la_LDFLAGS = -module -avoid-version
@@ -178,6 +202,8 @@ libyahoojp_la_LIBADD = \
libyahoo_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-yahoo.c \
+ empathy-accounts-plugin-yahoo.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libyahoo_la_LDFLAGS = -module -avoid-version
@@ -190,6 +216,8 @@ libyahoo_la_LIBADD = \
libzephyr_la_SOURCES = \
empathy-accounts-plugin.c \
empathy-accounts-plugin.h \
+ empathy-accounts-plugin-zephyr.c \
+ empathy-accounts-plugin-zephyr.h \
empathy-accounts-plugin-widget.c \
empathy-accounts-plugin-widget.h
libzephyr_la_LDFLAGS = -module -avoid-version