aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-11-22 00:23:11 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-11-22 00:23:11 +0800
commitabb968c6cdc50023b248b328a403444e644619bc (patch)
tree677efd848554bd613de1f09f01d3146d1c911288 /tools/Makefile.am
parent52bc77159e915ea52e32b4d7873aa644f885a859 (diff)
downloadgsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.tar
gsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.tar.gz
gsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.tar.bz2
gsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.tar.lz
gsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.tar.xz
gsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.tar.zst
gsoc2013-empathy-abb968c6cdc50023b248b328a403444e644619bc.zip
Update tools to latest version of tp-glib and include a gitignore
svn path=/trunk/; revision=1883
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am29
1 files changed, 19 insertions, 10 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bd1f4c002..817100087 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -7,41 +7,50 @@ telepathy-glib-env: telepathy-glib-env.in Makefile
chmod +x $@
EXTRA_DIST = \
- c-constants-generator.xsl \
+ c-constants-gen.py \
check-coding-style.mk \
check-c-style.sh \
check-misc.sh \
check-whitespace.sh \
- c-interfaces-generator.xsl \
doc-generator.xsl \
glib-client-gen.py \
glib-client-marshaller-gen.py \
- glib-errors-enum-body.xsl \
- glib-errors-enum-header.xsl \
- glib-interfaces-generator.xsl \
- glib-interfaces-body-generator.xsl \
+ glib-errors-enum-body-gen.py \
+ glib-errors-enum-header-gen.py \
glib-ginterface-gen.py \
glib-gtypes-generator.py \
+ glib-interfaces-gen.py \
glib-signals-marshal-gen.py \
gobject-foo.py \
identity.xsl \
+ lcov.am \
+ libtpcodegen.py \
libglibcodegen.py \
- ls-interfaces.xsl \
- make-all-async.xsl \
- spec-to-introspect.xsl \
+ make-version-script.py \
+ telepathy.am \
telepathy-glib-env.in \
with-session-bus.sh
-CLEANFILES = libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
+CLEANFILES = libtpcodegen.pyc libtpcodegen.pyo libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
all: $(EXTRA_DIST)
+libglibcodegen.py: libtpcodegen.py
+ touch $@
+c-constants-gen.py: libglibcodegen.py
+ touch $@
glib-client-marshaller-gen.py: libglibcodegen.py
touch $@
+glib-errors-enum-body-gen.py: libglibcodegen.py
+ touch $@
+glib-errors-enum-header-gen.py: libglibcodegen.py
+ touch $@
glib-ginterface-gen.py: libglibcodegen.py
touch $@
glib-gtypes-generator.py: libglibcodegen.py
touch $@
+glib-interfaces-gen.py: libglibcodegen.py
+ touch $@
glib-signals-marshal-gen.py: libglibcodegen.py
touch $@