aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorXavier Claessens <xclaesse@src.gnome.org>2008-02-26 21:31:02 +0800
committerXavier Claessens <xclaesse@src.gnome.org>2008-02-26 21:31:02 +0800
commitc3751daec7cca3e44abfed1db475cf0fc4703d66 (patch)
tree4ba009a19d6f3254acb8d91be788d49a7e259fc2 /tools/Makefile.am
parent035e672692a3c63ccf7b927b0b7b74438c1f0e24 (diff)
downloadgsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.tar
gsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.tar.gz
gsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.tar.bz2
gsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.tar.lz
gsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.tar.xz
gsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.tar.zst
gsoc2013-empathy-c3751daec7cca3e44abfed1db475cf0fc4703d66.zip
Import tools from telepathy-glib 0.7.3 and build a static libemp-extensions.la.
Link that library into libempathy (it's not actually used for anything at this point). Extensions currently built: ChannelHandler and StreamEngine. The namespacing convention used is emp_*, Emp*, EMP_* so it won't be included in the library ABI. svn path=/trunk/; revision=663
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
new file mode 100644
index 000000000..4bf514f16
--- /dev/null
+++ b/tools/Makefile.am
@@ -0,0 +1,41 @@
+EXTRA_DIST = \
+ c-constants-generator.xsl \
+ check-coding-style.mk \
+ check-c-style.sh \
+ check-misc.sh \
+ check-whitespace.sh \
+ c-interfaces-generator.xsl \
+ doc-generator.xsl \
+ glib-client-gen.py \
+ glib-client-marshaller-gen.py \
+ glib-errors-enum-body.xsl \
+ glib-errors-enum-header.xsl \
+ glib-interfaces-generator.xsl \
+ glib-interfaces-body-generator.xsl \
+ glib-ginterface-gen.py \
+ glib-gtypes-generator.py \
+ glib-signals-marshal-gen.py \
+ identity.xsl \
+ libglibcodegen.py
+
+CLEANFILES = libglibcodegen.pyc libglibcodegen.pyo $(noinst_SCRIPTS)
+
+all: $(EXTRA_DIST)
+
+glib-client-marshaller-gen.py: libglibcodegen.py
+ touch $@
+glib-ginterface-gen.py: libglibcodegen.py
+ touch $@
+glib-gtypes-generator.py: libglibcodegen.py
+ touch $@
+glib-signals-marshal-gen.py: libglibcodegen.py
+ touch $@
+
+TELEPATHY_GLIB_SRCDIR = $(top_srcdir)/../telepathy-glib
+maintainer-update-from-telepathy-glib:
+ set -e && cd $(srcdir) && \
+ for x in $(EXTRA_DIST); do \
+ if test -f $(TELEPATHY_GLIB_SRCDIR)/tools/$$x; then \
+ cp $(TELEPATHY_GLIB_SRCDIR)/tools/$$x $$x; \
+ fi; \
+ done