aboutsummaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-09-17 16:26:43 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-09-17 16:44:06 +0800
commit8750c21d6838bd83065f735470fb96de867ed31f (patch)
tree3ff8457567480e3fc6dbca285c3559b19acec2c4 /tools/Makefile.am
parentf9a38137925ff6f712afe21961614a1efb3b35ea (diff)
downloadgsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.tar
gsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.tar.gz
gsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.tar.bz2
gsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.tar.lz
gsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.tar.xz
gsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.tar.zst
gsoc2013-empathy-8750c21d6838bd83065f735470fb96de867ed31f.zip
sync tools/* with tp-glib master
Fix extensions/Makefile.am to build with the new tools.
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am19
1 files changed, 8 insertions, 11 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 49bcb04b5..80f4ce346 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -26,7 +26,6 @@ EXTRA_DIST = \
glib-ginterface-gen.py \
glib-gtypes-generator.py \
glib-interfaces-gen.py \
- glib-signals-marshal-gen.py \
gobject-foo.py \
lcov.am \
libtpcodegen.py \
@@ -48,23 +47,21 @@ CLEANFILES = libtpcodegen.pyc libtpcodegen.pyo libglibcodegen.pyc libglibcodegen
all: $(EXTRA_DIST)
libglibcodegen.py: libtpcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
c-constants-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
glib-client-marshaller-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
glib-errors-enum-body-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
glib-errors-enum-header-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
glib-ginterface-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
glib-gtypes-generator.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
glib-interfaces-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
-glib-signals-marshal-gen.py: libglibcodegen.py
- $(AM_V_GEN)touch $@
+ $(AM_V_GEN)test -e ${srcdir}/$@ && touch ${srcdir}/$@
TELEPATHY_SPEC_SRCDIR = $(top_srcdir)/../telepathy-spec
maintainer-update-from-telepathy-spec: