aboutsummaryrefslogtreecommitdiffstats
path: root/tests/interactive/Makefile.am
diff options
context:
space:
mode:
authorEmanuele Aina <emanuele.aina@collabora.com>2013-03-28 19:32:45 +0800
committerEmanuele Aina <emanuele.aina@collabora.com>2013-04-01 18:23:44 +0800
commit15460fa9ae4e6a19e8b6e971014deb50746d90ee (patch)
tree18db9db5b9ea32420080dcc8b8332f4998f9d365 /tests/interactive/Makefile.am
parent5c440c4e08f8102a9b73244697e69ad4855dbdef (diff)
downloadgsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.gz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.bz2
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.lz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.xz
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.tar.zst
gsoc2013-empathy-15460fa9ae4e6a19e8b6e971014deb50746d90ee.zip
Use a flat namespace for internal includes
Directly add the libempathy, libempathy-gtk and extensions directories to the include search path. This decouples header inclusions from their location and helps when reorganizing the source files layout. https://bugzilla.gnome.org/show_bug.cgi?id=696950
Diffstat (limited to 'tests/interactive/Makefile.am')
-rw-r--r--tests/interactive/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/interactive/Makefile.am b/tests/interactive/Makefile.am
index 27fdbf7e4..4ca1989ee 100644
--- a/tests/interactive/Makefile.am
+++ b/tests/interactive/Makefile.am
@@ -1,6 +1,7 @@
AM_CPPFLAGS = \
$(ERROR_CFLAGS) \
- -I$(top_srcdir) \
+ -I$(top_srcdir)/libempathy \
+ -I$(top_srcdir)/libempathy-gtk \
-DPKGDATADIR=\""$(pkgdatadir)"\" \
$(EMPATHY_CFLAGS) \
$(WARN_CFLAGS) \