aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2014-01-06 22:23:16 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2014-01-06 22:41:30 +0800
commit57396500ea506ca42677292b6ab8e0cf664e5f7f (patch)
treef61da94f8e46787532dec185e31ea2310c2ba65d /tests/Makefile.am
parent1bb72627c34c990adb807a633464ee9ca276290e (diff)
downloadgsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.tar
gsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.tar.gz
gsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.tar.bz2
gsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.tar.lz
gsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.tar.xz
gsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.tar.zst
gsoc2013-empathy-57396500ea506ca42677292b6ab8e0cf664e5f7f.zip
run coding style checks on tests
https://bugzilla.gnome.org/show_bug.cgi?id=721484
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c49c2007f..863282627 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -65,6 +65,18 @@ empathy_parser_test_SOURCES = empathy-parser-test.c \
empathy_live_search_test_SOURCES = empathy-live-search-test.c \
test-helper.c test-helper.h
+check_c_sources = \
+ $(empathy_tls_test_SOURCES) \
+ $(empathy_irc_server_test_SOURCES) \
+ $(empathy_irc_network_test_SOURCES) \
+ $(empathy_irc_network_manager_test_SOURCES) \
+ $(empathy_chatroom_test_SOURCES) \
+ $(empathy_chatroom_manager_test_SOURCES) \
+ $(empathy_parser_test_SOURCES) \
+ $(empathy_live_search_test_SOURCES)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
MC_PROFILE_DIR=@abs_top_srcdir@/tests \
MC_MANAGER_DIR=@abs_top_srcdir@/tests