aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-04-19 13:56:49 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2012-04-19 22:43:19 +0800
commitb0de75186e8e529e427aae231b334a3e40e5bffd (patch)
tree52897c323888ffd56eef648b10d26f7a92da9924 /tests/Makefile.am
parent7c25066261498dd98fb6bd1260ffe12f2fb5b7ce (diff)
downloadgsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.tar
gsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.tar.gz
gsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.tar.bz2
gsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.tar.lz
gsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.tar.xz
gsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.tar.zst
gsoc2013-empathy-b0de75186e8e529e427aae231b334a3e40e5bffd.zip
tls-test: Use a proper PKCS#11 mock module for testing
* In empathy-tls-test.c use a proper PKCS#11 mock module, which we can place certificate anchors and pinned certificates in. * Fix EmpathyTlsVerifier to check for server trust assertions not client ones, this was a bug highlighted by fixing tests. https://bugzilla.gnome.org/show_bug.cgi?id=668186 https://bugzilla.gnome.org/show_bug.cgi?id=668261
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b6c49509f..5b6d31f28 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,6 +16,7 @@ AM_CPPFLAGS = \
$(EMPATHY_CFLAGS) \
$(WARN_CFLAGS) \
$(DISABLE_DEPRECATED) \
+ -DSRCDIR=\""$(abs_srcdir)"\" \
$(NULL)
LDADD = \
@@ -38,7 +39,8 @@ noinst_PROGRAMS = $(tests_list)
TESTS = $(tests_list)
empathy_tls_test_SOURCES = empathy-tls-test.c \
- test-helper.c test-helper.h
+ test-helper.c test-helper.h \
+ mock-pkcs11.c mock-pkcs11.h
empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
test-helper.c test-helper.h \