aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-10-27 23:44:59 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-11-03 20:25:01 +0800
commitf053694701a9cb6c35fa0250c1a0b3374bd54395 (patch)
treee6279a3a2c8c57b1c9ed5ed505852efd06258f81 /tests/Makefile.am
parenta97016255a79a5b26af59411eab907d2881bc63e (diff)
downloadgsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.tar
gsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.tar.gz
gsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.tar.bz2
gsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.tar.lz
gsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.tar.xz
gsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.tar.zst
gsoc2013-empathy-f053694701a9cb6c35fa0250c1a0b3374bd54395.zip
port check-empathy-utils.c to GTest
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am25
1 files changed, 22 insertions, 3 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a93b6fd8a..21ee99bf8 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -23,14 +23,19 @@ LDADD = \
$(top_builddir)/libempathy/libempathy.la \
$(EMPATHY_LIBS)
-check_PROGRAMS = check-main
+TEST_PROGS = \
+ empathy-utils-test
+
+empathy_utils_test_SOURCES = empathy-utils-test.c
+
+check_PROGRAMS = check-main $(TEST_PROGS)
+
TESTS = check-main
check_main_SOURCES = \
check-main.c \
check-helpers.c \
check-helpers.h \
check-libempathy.h \
- check-empathy-utils.c \
check-empathy-helpers.h \
check-empathy-helpers.c \
check-irc-helper.h \
@@ -44,7 +49,7 @@ check_main_SOURCES = \
check_c_sources = \
$(check_main_SOURCES)
include $(top_srcdir)/tools/check-coding-style.mk
-check-local: check-coding-style
+check-local: test check-coding-style
check_main_LDADD = \
@CHECK_LIBS@ \
@@ -59,3 +64,17 @@ check_main_CFLAGS = \
TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
MC_PROFILE_DIR=@abs_top_srcdir@/tests \
MC_MANAGER_DIR=@abs_top_srcdir@/tests
+
+test-report: test-report.xml
+ gtester-report $(top_builddir)/tests/$@.xml > \
+ $(top_builddir)/tests/$@.html
+
+test-report.xml: ${TEST_PROGS} test
+
+test: ${TEST_PROGS}
+ gtester -o test-report.xml -k --verbose ${TEST_PROGS}
+
+test-%: empathy-%-test
+ gtester -o $@-report.xml -k --verbose $<
+
+.PHONY: test test-report