aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2010-12-10 05:51:28 +0800
committerStef Walter <stefw@collabora.co.uk>2010-12-24 21:40:02 +0800
commit34934197b7a1fb237c810c6de1aa498b4abbbc53 (patch)
tree6230dfdbcc26c4b6ef9063d9a71fa983fc47bfe2 /tests/Makefile.am
parent636f502149f77a80ef1b79cfc6d2da4b20c6ec7c (diff)
downloadgsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.tar
gsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.tar.gz
gsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.tar.bz2
gsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.tar.lz
gsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.tar.xz
gsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.tar.zst
gsoc2013-empathy-34934197b7a1fb237c810c6de1aa498b4abbbc53.zip
tests: Add mock object and test infrastructure for testing tls.
Create a mock o.f.T.Authentication.TLSCertificate object and connect to it in various tests. Loads certificate data from certificates/ subdir
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index a3bb71c31..ae18ac731 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -31,11 +31,15 @@ TEST_PROGS = \
empathy-chatroom-test \
empathy-chatroom-manager-test \
empathy-parser-test \
- empathy-live-search-test
+ empathy-live-search-test \
+ empathy-tls-test
empathy_utils_test_SOURCES = empathy-utils-test.c \
test-helper.c test-helper.h
+empathy_tls_test_SOURCES = empathy-tls-test.c \
+ test-helper.c test-helper.h
+
empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
test-helper.c test-helper.h \
test-irc-helper.h test-irc-helper.c