aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-10-29 22:51:27 +0800
committerGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2009-11-03 20:25:02 +0800
commitb3e65f73b24b69f3c6acd0dd662393259e13fc2d (patch)
treeef8aaffc3cd416d2d18018d4a95d20736d9884bb /tests/Makefile.am
parentfe119ac9b883091e0ed3e0b3cbbb64bca753baad (diff)
downloadgsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.tar
gsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.tar.gz
gsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.tar.bz2
gsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.tar.lz
gsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.tar.xz
gsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.tar.zst
gsoc2013-empathy-b3e65f73b24b69f3c6acd0dd662393259e13fc2d.zip
remove check-*
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am30
1 files changed, 1 insertions, 29 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c49597188..61c6b78db 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,8 +2,6 @@ SUBDIRS = interactive xml
CLEANFILES=
-include $(top_srcdir)/rules/check.mak
-
SUPPRESSIONS=valgrind.supp dlopen.supp
EXTRA_DIST = \
@@ -53,33 +51,7 @@ empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
empathy_chatroom_manager_test_SOURCES = empathy-chatroom-manager-test.c \
test-helper.c test-helper.h
-check_PROGRAMS = check-main $(TEST_PROGS)
-
-TESTS = check-main
-check_main_SOURCES = \
- check-main.c \
- check-helpers.c \
- check-helpers.h \
- check-libempathy.h \
- check-empathy-helpers.h \
- check-empathy-helpers.c \
- check-irc-helper.h \
- check-irc-helper.c
-
-check_c_sources = \
- $(check_main_SOURCES)
-include $(top_srcdir)/tools/check-coding-style.mk
-check-local: test check-coding-style
-
-check_main_LDADD = \
- @CHECK_LIBS@ \
- $(top_builddir)/libempathy-gtk/libempathy-gtk.la \
- $(top_builddir)/libempathy/libempathy.la \
- $(AM_LDFLAGS)
-
-check_main_CFLAGS = \
- @CHECK_CFLAGS@ \
- $(AM_CFLAGS)
+check_PROGRAMS = $(TEST_PROGS)
TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
MC_PROFILE_DIR=@abs_top_srcdir@/tests \