aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPierre-Luc Beaudoin <pierre-luc.beaudoin@collabora.co.uk>2009-06-09 03:10:57 +0800
committerPierre-Luc Beaudoin <pierre-luc.beaudoin@collabora.co.uk>2009-06-09 05:02:32 +0800
commitb28c2c17566ac07565b98e6720c7a6a5ec927ad1 (patch)
treee7d805277f707c69bad625779f5cd7ec3a511cb6 /src/Makefile.am
parentcc548789733a60b077718c022b6b0e03fc793857 (diff)
downloadgsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.gz
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.bz2
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.lz
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.xz
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.tar.zst
gsoc2013-empathy-b28c2c17566ac07565b98e6720c7a6a5ec927ad1.zip
Distribute conditionally built files
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index db2117986..8102666c6 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -75,12 +75,22 @@ ui_DATA = \
empathy-preferences.ui \
empathy-status-icon.ui
+EXTRA_DIST = \
+ $(autostart_DATA) \
+ $(ui_DATA)
+
if HAVE_LIBCHAMPLAIN
empathy_SOURCES += \
- empathy-map-view.c empathy-map-view.h
+ empathy-map-view.c \
+ empathy-map-view.h
ui_DATA += \
empathy-map-view.ui
+else
+EXTRA_DIST += \
+ empathy-map-view.c \
+ empathy-map-view.h \
+ empathy-map-view.ui
endif
dist_man_MANS = \
@@ -104,9 +114,5 @@ dist_man_MANS = \
--vtail " { 0, NULL, NULL }\n };\n etype = g_@type@_register_static (\"@EnumName@\", values);\n }\n return etype;\n}\n" \
$< > $@
-EXTRA_DIST = \
- $(autostart_DATA) \
- $(ui_DATA)
-
CLEANFILES = $(BUILT_SOURCES)